The title is weird & we know it – if you read on, you’ll understand why its there. This post is related to the recently released PC game Alpha Protocol. I have had the chance to play licensed version of this game for a few hours and it has so far played like a mediocre 3rd person RPG. I ran into an annoying bug where the game won’t save the state properly and there’d be slight changes (for example to player position) when a save is loaded. On the plus side, the story and game play concepts look pretty good. Although the game is not broken, it did not look anything special either. Anyways here’s answers to a few questions asked by our readers so far; How to change language in Alpha Protocol & more importantly, what’s with the weird moaning sounds you get in the main menu.

How to change language in Alpha Protocol

If your version of Alpha protocol runs in any other language than English (and if you want the game to switch to English), try the fix below.

  1. Go to X:\Users\USERNAME\Documents\Alpha Protocol\APGame\Config\APEngine (where X: is your system drive, usually C:) and open the APEngine.ini file with a text editor.
  2. Scroll to the [Engine.Engine] section and set Language=EN. Save and close the file.
  3. Go to X:\Program Files\SEGA Corporation\Alpha Protocol\Engine\Config\BaseEngine and Open BaseEngine.ini file with a text editor.
  4. Scroll to the [Engine.Engine] section and set Language=EN. Save and close the file. Now start the game.

If you want to change the language to any other language than English, you may try a different language string. For example to switch it to Russian set Language=RUS. For this to work your copy of the game must be a MULTILANGUAGE version.

How to Fix Crashes, weird menu sounds, game exiting to main menu after the first cutscene, etc

We’ve received several E-mails from our readers who all seem to have run into a very weird issue. Whenever a menu item is selected/hovered on, the game would emit a strange moaning sound :D Apart from that it would crash to desktop or go back to the main menu after the first cut scene. From what I have found so far, this happens when you try different versions of the game in your machine. For example if you installed a leaked copy of the game earlier and then tried installing the legit version (or a different exe) later, these problems may materialize. To try and resolve these issues, follow the instructions below.

Note: Be careful when making changes to the system registry. Deleting/modifying wrong values may cripple your system.

  1. Open the Windows Registry Editor – this is usually done by typing RegEdit.exe in the run/search box and pressing enter.
  2. Expand the key HKEY_LOCAL_MACHINE and then expand SOFTWARE
  3. Right click the ‘SEGA Corporation’ Key (under SOFTWARE) and hit delete. Press yes to the confirmation message. Close the Registry Editor.
  4. Navigate to X:\ProgramData directory, where X is your system drive (usually C:\). Delete the SEGA Corporation folder located inside it. Now run the game.

If the above does not work, try uninstalling the game, repeating steps 1-4 and then reinstalling a fresh copy.

How to improve mouse controls and mouse movement in Alpha Protocol

If you are annoyed by the way your mouse behaves in Alpha Protocol (sudden mouse speed variations when FPS drops), you can try the following fix to improve mouse handling. Full credit for this fix goes to user MirkoOdora on NFoHump Forums.

  1. Go to X:\Users\USERNAME\Documents\Alpha Protocol\APGame\Config & open DefaultInput.ini file with a text editor. Set  bEnableMouseSmoothing=False in this file, save and close it.
  2. Go to X:\Users\USERNAME\Documents\Alpha Protocol\APGame\Config & open APInput.ini file. Set all occurrences of bEnableMouseSmoothing variable in this file (there should be 2) to bEnableMouseSmoothing=False
  3. Go to X:\Users\USERNAME\Documents\Alpha Protocol\APGame\Config & open APEngine.ini file. Set the following values in appropriate sections
    [Engine.GameEngine]
    bSmoothFrameRate=FALSE
    MinSmoothedFrameRate=1024
    MaxSmoothedFrameRate=4096
    [SystemSettings]
    UseVsync=False
  4. Open X:\Users\USERNAME\Documents\Alpha Protocol\APGame\Config and make all ini files in this folder read only (note – after making these files read only, your changes from the in game menu options may not get saved. If you need to change any settings from the in game menu, it’s suggest that you do it before this step)

Note: This article is a work in progress. Check back here frequently for updates as we will be adding new content when more fixes are discovered.

If you liked this article do not forget to subscribe to our RSS feed. We bring you the latest BitTorrent news, private torrent tracker updates, leaks, downloads and more.
You can also follow us on Twitter.


6 Comments

  1. Triad_470 // 5/28/2010 01:01:00 PM  

    Great stuff bro. Registry fix stopped the weird menu sounds. Thanks.

  2. Duncan // 5/31/2010 02:58:00 PM  

    Fantastic, thanks for your help!

  3. Josh // 7/23/2010 05:31:00 AM  

    Registry fix didnt work, didnt have a SEGA key listed :(

  4. Joost // 9/18/2010 08:17:00 PM  

    Brilliant man, thanks! That stopped the moaning and got the game to work!

  5. mostafa // 4/01/2011 09:27:00 PM  

    you are the best

  6. coolhacker95 // 5/19/2013 01:07:00 AM  

    i dont think i have a multi-language pack...can i download th english pack from somewhere???