Scene group RELOADED have done it once again. They've managed to release the expansion pack to popular game Command and Conquer 3, four days before its street date. This release is now available on private and public bittorrent trackers across the globe.


Experience a new story that spans 20 years with Command & Conquer 3: Kane's Wrath. From the rebirth of the Brotherhood of Nod after the Second Tiberium War through the dramatic events of the Third Tiberium War and beyond. Command & Conquer 3: Kane's Wrath is told through a new set of high- definition live action video sequences starring a celebrity cast. Joe Kucan, the original actor who portrayed the character Kane in Command & Conquer games over the last decade, will reprise his role as the megalomaniacal leader of the Brotherhood of Nod.

Command & Conquer 3: Kane's Wrath also features a new strategic layer of gameplay that allows you to establish bases, build customised armies, and attack your enemies on a global scale - and then dive into the frenzied tactical combat where your skills as a commander will be tested to the limits. Command & Conquer 3: Kane's Wrath introduces six new sub-factions
and a wealth of new units, structures, and powers to the armies of the Global Defense Initiative, the Brotherhood of Nod, and the enigmatic alien Scrin.

Note: You will need to original game to run this expansion.

Read comments for more information.


  1. Lightning_Struck_Tower // 3/20/2008 10:40:00 PM  
    This comment has been removed by a blog administrator.
  2. Lightning_Struck_Tower // 3/21/2008 12:36:00 AM  
    This comment has been removed by a blog administrator.
  3. Priyantha De Silva // 3/21/2008 07:40:00 PM  

    @ LST,

    I've a problem regarding Quick Time . I had version 6...., got with Oxford dictionary. After downloading Quick Time 7.4... it.s not working. ( Can't here the words of the dictionary). If I un - installed the new one , it's working. I've downloaded new Quick Times , 2 times and nothing works.

    * If I use new version, Can't use the Oxford Dictionary ,
    * If I use older one, can't use I-Tune radio etc.

    Is there any register codes available to make new one Ok, or any other methods ?

    Thank you !!!

  4. Priyantha De Silva // 3/21/2008 07:43:00 PM  

    7.4 is working from the beginning. My problem is it's not compatible with "Oxford Advanced Learners Dictionary", which always use.

  5. Lightning_Struck_Tower // 3/22/2008 05:48:00 PM  

    It's better if you stick to newer version of quicktime and use Babylon translator instead of oxford dic.

    Babylon has oxford concise dictionary + thesaurus already built into it:

  6. Priyantha De Silva // 3/23/2008 02:00:00 AM  

    OK, Thanks, I'll try now.

  7. Jenefee Mike // 4/02/2015 02:36:00 PM  

    You should comment on the competition comparison of the blog. You can highlight it's mind boggling. Your blog exploration/tour will broaden your conversions. Berita Arsenal