LOST: Via Domus

Posted by TEAM FILEnetworks | 2/27/2008 | | 8 Comments »

After Oceanic Air flight 815 tore apart in mid-air and crashed on a seemingly deserted Pacific island, its survivors were forced to find inner strength they never knew they had in order to survive. The band of friends, family, enemies and strangers has become reluctant heroes who must work together against the cruel weather and harsh terrain if they want to stay alive. Danger and mystery loom behind every corner on the island, and those they thought could be trusted may turn against them. Even heroes have secrets.

Game features:

  • Play as a survivor of Oceanic Flight 815: Confront your dark past, seek your redemption, and ultimately find a way home
  • Explore familiar locations, unravel mysteries, and interact with the main characters from the show
  • Solve puzzles, outsmart enemies, battle the smoke monster, and overcome many other challenges to survive the island and come out alive

Minimum system requirements:

  • Supported OS: Windows Vista /XP (only)
  • Processor: 2.4 GHz Intel Pentium 4 orAMD Athlon MP 2400+ (3.5 GHz Pentium 4/AMD Athlon or 2.5 GHz Core 2 Duo/Athlon 64 X2 recommended)
  • RAM: 1 GB (2 GB recommended)
  • Video Card: 128 MB DirectX 9.0c–compliant, Shader 3.0–enabled video card (256MB recommended)
  • Hard Drive Space:5 GB

Read comments for more information.


  1. Lightning_Struck_Tower // 2/27/2008 02:24:00 AM  
    This comment has been removed by a blog administrator.
  2. Maddy // 2/28/2008 03:56:00 PM  

    Hey thanks LST but ll it wrk on 1GB ram?
    its says 2gb recommended
    did u try it?

  3. Lightning_Struck_Tower // 2/29/2008 01:37:00 AM  

    i tried it on a 2gb machine. It ran smoothly on 2gb. It should work on 1gb but there may be some lagging. But should be playable if your vga does not share system memory.

  4. Maddy // 2/29/2008 08:47:00 AM  

    my VGA is NVIDIA FeForce FX 5200LE, so i hope there is a chance to play. let see im downloadin the game now.

    Thanks for sharing ...

  5. Lightning_Struck_Tower // 2/29/2008 10:01:00 AM  

    The game requires shader model 3 enabled VGA.

    FX series has 2.0 o in that case game might not run at all. Shader 3.0 available only from geforce 6 series and above.

  6. Maddy // 2/29/2008 10:28:00 AM  

    oops ...

  7. Maddy // 3/05/2008 10:03:00 AM  

    LST will it work on GEFORCE 8500GT (foxconn) ?

  8. Lightning_Struck_Tower // 3/05/2008 11:19:00 PM  

    maddy it'll definitely work in 8500GT. Probably in mid-high setting too.